CVE-2019-11038 (debian_linux, enterprise_linux, fedora, leap, libgd, linux_enterprise_debuginfo, linux_enterprise_desktop, linux_enterprise_server, linux_enterprise_software_development_kit, linux_enterprise_workstation_extension, php, software_collections, ubuntu_linux)

When using the gdImageCreateFromXbm() function in the GD Graphics Library (aka LibGD) 2.2.5, as used in the PHP GD extension in PHP versions 7.1.x below 7.1.30, 7.2.x below 7.2.19 and 7.3.x below 7.3.6, it is possible to supply data that will cause the function to use the value of uninitialized variable. This may lead to disclosing contents of the stack that has been left there by previous code.

View Full Alert

Leave a Reply